Author Topic: Mac OS version - Plays tracks too fast? [RESOLVED]  (Read 12209 times)

ajbezark

  • Guest
Mac OS version - Plays tracks too fast? [RESOLVED]
« on: January 19, 2010, 09:30:00 am »
Just found out about the new Mac OSX version of VinylStudio and immediately downloaded it. It should be a great solution for my USB turntable. But so far, I've gotten stuck right at the first step: audio capture.

I have an ION USBTT05 USB turntable. It's connected to one of the USB ports on my 2007 MacBook Pro 17". I'm running OS X 10.6.2 (Snow Leopard).

When I try to record an LP from the turntable, I use the "Check Level" button to hear how the LP sounds - but I hear "choppy" sound that cuts in and out very rapidly. This choppiness occurs on "Record" as well as "Check Level."

Then, when I try to play back the recording, the choppiness is gone... but the recording is twice as fast as the original music (and the pitch is higher).

This happens whether I record live from the turntable, or whether I import the songs from an existing.

In any case, please advise. I'm able to send sound files if needed.

Thanks!
« Last Edit: January 30, 2010, 06:19:43 pm by Paul Sanders (AlpineSoft) »

Paul Sanders (AlpineSoft)

  • Administrator
  • Staff
  • *****
  • Posts: 1180
    • AlpineSoft Main Website
Re: Mac OS version - Plays tracks too fast?
« Reply #1 on: January 19, 2010, 10:24:35 am »
Have you got speed conversion enabled (there's a checkbox in the record screen that turns it on and off)?  That's probably why the recording is playing too fast.

I'm not sure why the monitored sound is so choppy - we don't get that here.  I will investigate and report back here in due course.

ajbezark

  • Guest
Re: Mac OS version - Plays tracks too fast?
« Reply #2 on: January 19, 2010, 04:39:55 pm »
Have you got speed conversion enabled (there's a checkbox in the record screen that turns it on and off)?  That's probably why the recording is playing too fast.

Hi, Paul -
Thanks for the quick reply. No, I don't have speed conversion enabled. (That's a recording feature, right? I've tried checking it during playback, but it doesn't seem to make any difference.)

Could it be a bitrate issue? I'm not an audio guy, but wouldn't there be a problem if VS was recording at one bitrate (say 22kHz) and playing back at a faster rate (say 44kHz)? I've been using the standard VS preset of 44kHz, 16 bits per sample.

I'm trying to find out what bitrate the ION USBTT05 turntable uses. Is there a standard? Could a mismatch between turntable and software cause this problem?

Again, when I use the same setup with other software such as Final Vinyl, it sounds fine. But you guys appear to have much more robust editing and cleanup features, so I'm eager to get VS working soon. Thanks!

Paul Sanders (AlpineSoft)

  • Administrator
  • Staff
  • *****
  • Posts: 1180
    • AlpineSoft Main Website
Re: Mac OS version - Plays tracks too fast?
« Reply #3 on: January 19, 2010, 05:25:43 pm »
Hi,

Yes, it's a recording feature.  Sorry, I should have mentioned that.

Please leave it with me for the moment - there are a few things I can try here to see if I can replicate the fault.  In the meantime, you might record in Final Vinyl and then import the resulting recordings into VinylStudio.  That will at least give you a chance to try out the other features of the program while we investigate this issue.

Regards,

Paul Sanders
AlpineSoft
http://www.alpinesoft.co.uk

ajbezark

  • Guest
Re: Mac OS version - Plays tracks too fast?
« Reply #4 on: January 19, 2010, 06:01:50 pm »
Please leave it with me for the moment - there are a few things I can try here to see if I can replicate the fault.  In the meantime, you might record in Final Vinyl and then import the resulting recordings into VinylStudio.  That will at least give you a chance to try out the other features of the program while we investigate this issue.

Hi, Paul -

Thanks again for the quick reply. Much appreciated.
I'll try recording in FV and importing to VS, but I've already imported an existing MP3 file (to an already open VS album), and it appended the new file, but the MP3 sounds just as speeded-up as the one recorded from the turntable.
Just one more clue, professor. Good luck!

Cheers,
Adam

ajbezark

  • Guest
Re: Mac OS version - Plays tracks too fast?
« Reply #5 on: January 19, 2010, 06:07:09 pm »
FWIW, I just checked, and it appears that the music is playing back at roughly 3x its proper speed.
I also closed the original album and re-imported the MP3 as a separate "single," and it still plays back at 3x.
I looked in the recordings folder, and the imported MP3 sounds normal when played in the finder instead of in VinylStudio.
« Last Edit: January 19, 2010, 06:18:52 pm by ajbezark »

Paul Sanders (AlpineSoft)

  • Administrator
  • Staff
  • *****
  • Posts: 1180
    • AlpineSoft Main Website
Re: Mac OS version - Plays tracks too fast?
« Reply #6 on: January 19, 2010, 06:22:09 pm »
Hi Adam,

Yes, that is a big clue, thank you.  The problem must be on the playback side rather than the recording side.  I bet if you play a recording made by VS in FV, it will sound OK.

The problem for me is that I don't have machine like yours to work on.  What I might do is write a little diagnostic program to tell me something about the audio hardware in your Macbook and ask you to run it for me and send back what it reports.  Would you be up for that?  Maybe then I can see what is confusing VinylStudio.  As you say, it seems to be confused over samplerates.  It won't be for a day or two though, there is a lot going on here!

Regards,

Paul Sanders
AlpineSoft
http://www.alpinesoft.co.uk

ajbezark

  • Guest
Re: Mac OS version - Plays tracks too fast?
« Reply #7 on: January 19, 2010, 07:05:01 pm »
Sure! I'll be happy to run the diagnostic and send you any results.
I'll also try some combinations of recording in FV and playing back in VS, and vice versa...
Just give me a shout whenever you're ready. Thanks!

Paul Sanders (AlpineSoft)

  • Administrator
  • Staff
  • *****
  • Posts: 1180
    • AlpineSoft Main Website
Re: Mac OS version - Plays tracks too fast?
« Reply #8 on: January 19, 2010, 07:58:09 pm »
OK, will do.  I will probably contact you off-list.  It will make things a bit easier.  I can post any conclusions back here afterwards.

Regards,

Paul Sanders
AlpineSoft
http://www.alpinesoft.co.uk

Paul Sanders (AlpineSoft)

  • Administrator
  • Staff
  • *****
  • Posts: 1180
    • AlpineSoft Main Website
Re: Mac OS version - Plays tracks too fast? [RESOLVED]
« Reply #9 on: January 30, 2010, 06:17:55 pm »
Update for interested readers: we finally got to the bottom of this and it will be fixed in V7.01 and later.

ajbezark

  • Guest
Re: Mac OS version - Plays tracks too fast? [RESOLVED]
« Reply #10 on: February 07, 2010, 02:33:48 am »
Update for interested readers: we finally got to the bottom of this and it will be fixed in V7.01 and later.

Yes! 7.01 does the trick. I just recorded my first LP, and everything went great. Thanks for the fast fix, Paul!

Paul Sanders (AlpineSoft)

  • Administrator
  • Staff
  • *****
  • Posts: 1180
    • AlpineSoft Main Website
Re: Mac OS version - Plays tracks too fast? [RESOLVED]
« Reply #11 on: February 07, 2010, 11:27:17 am »
Excellent :)  Thank you for taking the time to post.