Welcome to the AlpineSoft support forum.  To return to the main website, click here:

Main Menu

Last half second of recording not playable

Started by MikeyLL, June 29, 2023, 04:22:29 PM

Previous topic - Next topic


I have recently found that some (possibly all) of my recordings (in this case made from cassette) will not play the last half second or so of audio. I am fairly certain that this did not happen in the past (i.e. when I made the recordings and created the track breaks/removed dead space, which was many months ago), but going in to cleanup audio now shows an end of track marker at the very end of audio, but playback stops before this. I have tried deleting the last marker and reinserting but still no good.
all other tracks of the recording are good and I have found several examples of this happening (most are not noticeable because of a longer run out time where the audio is close to 0 for the last half second).
I have ensured that I have the latest version of VinylStudio available.
I don't really know how to diagnose what has gone wrong here, although I suspect it could be something I have done wrong!
The attachment shows the end of one of the files - where the playback cursor is is where it stops playing.
Any help would be appreciated.


Paul Sanders (AlpineSoft)


Looks like you have a cut in there.  Why's that?


Hello Paul
My normal method of recording and editing is:
Record complete track
cut beginning and end to remove unwanted dead space
Manually add track breaks as required
Perform cleanup if needed
Edit track names.
So the cut that you are referring to is the final cut of the track to remove dead space at the end of the recording.
When I performed this I would have listened to the audio to get the correct space to cut from, so I am confident that at that stage the recording would have played to the end.
I seem to recall that there was an issue at some point whereby after cuts were made (or maybe it was the track breaks) the displayed waveform did not update in some way to reflect the position of the breaks. This could be corrected by leaving the window and returning. Maybe this is something to do with it?

Paul Sanders (AlpineSoft)

OK, thanks.

A better way to do that is:
  • delete the existing cut (if any)
  • move the red last end-of-track marker to the left to elide the unwanted audio

Then see if the problem still persists.  Zoom in for better accuracy (and listen while you work).


Hello Paul

I have tried that and it does indeed seem to work, so I am guessing that there was some issue with actually having the cut at the end. I'm sure that this worked with no issues on older versions, but I am happy to have a solution.
Thanks for your assistance

Paul Sanders (AlpineSoft)

My best guess is that you didn't have the cut in quite the right place (or it was a bit too wide).  Using the track break markers is much easier and more accurate.


I have the same problem. It also occurs on recordings that have not had any edits done to them. Standard behaviour of Vinyl Studio in the cleanup audio window is to stop playback about half a second before the end of the file. Any suggestions?

Paul Sanders (AlpineSoft)

I can confirm this problem.  We will investigate, thank you.


Hello Paul
Thank you for looking into this.
If it helps I think this only started to happen after an update. I'm not sure exactly when as I may well not have noticed immediately, but it was certainly prior to may 2022

Paul Sanders (AlpineSoft)

Don't think so.  I've now looked into this and the code in question hasn't changed in a long time.

Anyway, that's all moot.  We'll include a fix in the next release, thanks again for reporting it.  In the meantime, saving tracks is not affected - they will not cut any audio off that they shouldn't.


I have version 13 installed (until a fix mentioned in another thread is done)


I have version 13 installed (until a fix mentioned in another thread is done) and the cursor stops before the end of the last track. I have a screenshot I am attaching to this message.  The issue started some time ago and it did not occur in previous versions, as far as I remember.

Paul Sanders (AlpineSoft)

OK, TU, will investigate


OK, should be fixed (along with much else) in V14.0.2 (so watch out for that, it's not out yet and V14.0.1 has a silly bug)