Welcome to the AlpineSoft support forum.  To return to the main website, click here:

Main Menu

Recording is distorted following motherboard replacement

Started by Javic, May 04, 2023, 09:36:30 PM

Previous topic - Next topic


I'm using Vinyl Studio (VS) on 64-bit Windows 7 SP1. My motherboard has on-board Realtek sound. I also have a SoundBlaster Audigy 2 ZS installed.

The SB card is well known for having problems with recording under 64-bit Windows. If I use it's input for recording, sound is badly garbled. So following advice I found elsewhere, I'm using the onboard Realtek device for input, and the SB device for output. On the Realtek device, all outputs and all inputs other than line-in are disabled; my phono preamp is connected to line-in. On the SB device, all inputs and all outputs other than speakers are disabled.

I had this set-up working perfectly for months. Then two weeks ago my motherboard failed. I replaced it with a duplicate (i.e, same make and model). I've had no problems until today when I tried to record an album for the first time after installing the new mobo. (FWIW I also just upgraded VS from version 12.X to 13.0.)

Now, I'm getting garbled sound during the "Check Levels" step in VS. It's not as bad as when trying to record through the SB, but it still makes recording impossible. I would describe the distortion as a regular, almost pulsating, minor but audible drop-out, or a very brief repeating skip (at first I thought the record was scratched, but it's not, and the effect is there regardless of album). On playback, things are even worse. It sounds almost like there are two recordings, overlapping or interleaved. That is, it's as if VS is recording from two inputs that are slightly out-of-sync. FWIW I have several albums I recorded weeks ago and they play back fine, so it's apparently an issue with recording, not playback.

Anybody have an idea about what's causing the problem, or suggestions for further diagnosis? Is it possible some VS setting needs adjustment? Finally, did something change in VS 13.0 that might account for this? (Installing VS 13.0 is the only software change I've made to my system since replacing the mobo.)

Paul Sanders (AlpineSoft)


It's actually a VinylStudio 13 thing.  The Realtek drivers seem to have a bug in them and VinylStudio's (new) default recording method triggers it.

We will change the default in the next release, but in the meantime changing the Host dropdown in VinylStudio's Check Level dialog to WASAPI exclusive polled should fix it.


That fixed it. Thank you so much! I had considered reverting to VS 12.x as an experiment, but thought it more likely it was the motherboard swap that was at fault. Very happy it was such an easy fix. Thanks again.